Home | Net Issues | Net How To | Wireless | Case Studies | Articles | Forums | Services | Donations | Careers | About Us | Contact Us|

Web Cisco
 

Example of Cisco Router configuration

version 12.4
no service timestamps debug uptime
service timestamps log datetime msec
service password-encryption
!
hostname CHICAGOTECH
!
boot-start-marker
boot system flash c2800nm-advsecurityk9-mz.124-12.bin
boot-end-marker
!
card type t1 0 0
no logging on
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
enable password xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
no aaa new-model
memory-size iomem 25
clock timezone cst -6
clock summer-time CDT recurring
no network-clock-participate wic 0
no ip source-route
ip wccp 91 redirect-list WCCPUSER
!
ip cef
!
ip name-server 206.166.xx.xx
!
controller T1 0/0/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/0/1
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
class-map match-all OWA
match access-group 13
class-map match-all CBG1MB
match access-group name CBG1MB
!
!
policy-map CHICAGOTECH
class OWA
bandwidth percent 30
class CBG1MB
police rate 1000000
conform-action transmit
exceed-action drop
violate-action drop
!
interface Loopback0
ip address 65.79.x.xx 255.255.255.255
!
interface Multilink15
description CHICAGOTECH NET MLPPP
ip address 206.166.xx.xxx 255.255.255.252
ip wccp 91 redirect out
load-interval 30
ppp multilink
ppp multilink fragment disable
ppp multilink group 15
service-policy output CHICAGOTECH
!
interface FastEthernet0/0
ip address xx.xxx.43.193 255.255.255.224
ip access-group 33 out
duplex full
speed 100
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:0
description SOIB25 - S6/0/0/19:0 --> CHICAGOTECH NET - DHZA234340
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 15
!
interface Serial0/0/1:0
description SOIB25 - S5/0/3/24:0 --> CHICAGOTECH NET - DHZA045978
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 15
!
interface Serial0/1/0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 15
!
ip route 0.0.0.0 0.0.0.0 Multilink15
!
no ip http server
no ip http secure-server
!
ip access-list extended CBG1MB
permit ip host xx.xxx.43.210 any
permit ip host xx.xxx.43.220 any
permit ip host xx.xxx.43.219 any
permit ip host xx.xxx.43.221 any
permit ip host xx.xxx.43.218 any
permit ip host xx.xxx.43.217 any
ip access-list extended WCCPUSER
deny ip any host 163.191.183.110
deny ip any host 129.41.23.161
deny ip any host 204.153.51.42
deny ip any host 129.41.23.179
deny ip any host 192.84.80.37
deny ip any host 66.99.246.227
deny ip any host 204.228.64.38
deny ip any host 66.170.17.71
deny ip any host 204.228.64.37
deny ip any 129.41.4.0 0.0.0.255
permit tcp host xx.xxx.43.222 any eq www
!
access-list 12 permit xx.xxx.43.201
access-list 13 permit xx.xxx.43.195
access-list 33 deny 220.73.220.4
access-list 33 permit any
snmp-server engineID local 0000000902000004C13F36D9
snmp-server system-shutdown
snmp-server enable traps tty
snmp-server enable traps config
!
!
control-plane
!
line con 0
exec-timeout 5 0
password xxxxxxxxxxxxxxxx
line aux 0
exec-timeout 5 0
password xxxxxxxxxxxxxxxxxx
line vty 0 4
access-class 95 in
exec-timeout 5 0
password xxxxxxxxxxxxxxxxxxxxxxxxxx
login
!
scheduler allocate 20000 1000
!
end

 

Post your questions, comments, feedbacks and suggestions

Contact a consultant

Related Topics

 

 

  This web is provided "AS IS" with no warranties.
Copyright © 2002-2007 ChicagoTech.net, All rights reserved. Unauthorized reproduction forbidden.